• XenDesktop 7.6 NetScaler Gateway SmartAccess

    by  • May 2, 2015 • 2 Comments

    Recently, I ran into an odd issue where SmartAccess was not working on a XenDesktop 7.6 environment. It turns out that NetScaler Gateway SmartAccess depends on XML requests which need to be enabled. In the past, there was a policy to Trust Requests Sent to the XML Service Port, however, this policy has been...

    Read more →

    Citrix on OSX 10.10 Yosemite

    by  • April 11, 2015 • 1 Comment

    Back in October, 2013, I wrote an article on how to fix latency for Citrix on OS X 10.9 (Mavericks), it turns out that this issue which was related to Mac OS has not been resolved as of OS X 10.10 (Yosemite). Below is a recap of the fix if you are experiencing latency...

    Read more →

    VBScripts and UAC

    by  • April 11, 2015 • 0 Comments

    I love writing scripts, however, User Account Control (UAC) can sometimes be a pain in the neck which is why I have looked for ways around scripting in customer environments that have UAC enabled. The following are my current solutions: VBScripts and UAC elevation With User Account Control (UAC) enabled, one needs to open...

    Read more →

    XenServer 6.1 Limitations

    by  • January 4, 2013 • 3 Comments

    Virtual Machine Limits CPU Limits Virtual CPUs per Virtual Machine 16 Memory RAM per Virtual Machine 128 GB Storage Virtual disks (including CD-ROM) per Virtual Machine 16 Virtual CD-ROM drives per Virtual Machine 1 Virtual Disk Size (NFS) 2TB minus 4 MB Virtual Disk Size (LVM) 2TB minus 4 MB Networking Virtual NICs per...

    Read more →

    Monitoring XenServer

    by  • April 20, 2012 • 0 Comments

    Now that XenServer’s feature set has expanded one of the questions that I commonly get is “How do you monitor XenServer?” While this will greatly depend on how complex the environment is and what the administrators would like to ultimately monitor.  For starters, most of the data that can be collected from XenServer will...

    Read more →

    How to Fix most PVS 6 and 6.1 issues

    by  • March 1, 2012 • 0 Comments

    In recent conversations with enterprise customers, it has become very noticeable that Provisioning Server 6.0 and 6.1 have multiple issues that span anywhere from vDisks not being able to connect to their respective servers, black screens when attempting to stream an image to a target device, problems with IPs and DNS entries not working...

    Read more →

    XenServer 6 XE Command Reference

    by  • January 31, 2012 • 2 Comments

    With the new installment of XenServer, there have been some modifications to the CLI commands, Bjorn Andersson from Diverse Tips has created a very nice printable PDF poster that encompasses all of the XE commands available for this new version of XenServer. The image below is a preview of what is available on this PDF poster. The...

    Read more →

    Configuring XenServer LogRotate

    by  • December 13, 2011 • 1 Comment

    In XenServer environments I have seen issues with logs filling up the entire Dom0 storage allocation.  The reason behind this is that XenServer logrotate feature can break as it cannot parse the size parameter properly and this results in the dom0 Storage allocation becoming full, caused by overgrown Log Files.  Since Citrix frowns upon...

    Read more →

    Cache Corruption with Provisioning Server 6.0

    by  • December 12, 2011 • 2 Comments

    Upon working in environments with the brand new PVS 6.0, I have ran across a bnistack corruption issue.  This issue exists in PVS 5.6SP2 environments and ended up in the latest releases of PVS 6.0.  If you are running into some weird profile corruption problems or random loss of data within a Provisioned image...

    Read more →